Diesel Jeep Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just picked up a 2015 Grand Cherokee with the CRD and 48,000 miles. It was an auction purchase, so its previous life is unknown.

It starts up fine, but when you put it in gear and try to take off, it sputters badly and will not accelerate over about 10 MPH, bucking all the way.

It idles fine, and you can rev the engine up in Park or Neutral with no indication of an issue.

If you drive it around for a mile or so, sometimes it will come to life and accelerate normally, but if/when it does, it spews tons of white smoke out of the tailpipes. Once you turn it off and it cools down, it starts acting up again.

No check engine light, and no codes according to my code reader.

The only indication of an issue on the dash is that the Traction Control light is on and will not go off. I don't think that's related, but who knows?

The engine is not running hot, and coolant does not seem to be disappearing, so I don't think it is a head gasket issue. Oil does not seem to have water in it either.

Any idea what would cause this? Could water in the diesel fuel cause this? The water in fuel light is not on, but it sure seems to act like it has water in the diesel.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Well, it started running normally, but the ESC light was on and it won't go into 4WD. Took it to the dealer, and they are replacing the Drivetrain Control Module. Not cheap, but hopefully that'll take care of the issues.
 
1 - 2 of 2 Posts
Top