Diesel Jeep Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
While we haven't had any issues with the DEF, there is one minor annoyance that our dealer cannot figure out. First we live in AZ, so I don't think it's a "cold" issue. However when we first drive our GC, whether in the morning or it sits all day and drive in the afternoon..."usually" within the first 5 min the engine will "hiccup". Sometimes mild and sometimes it will snap your head.

Unfortunately it has been random enough that the dealer has not experienced it...even after keeping the GC for up to 3 days.

It usually only does it once and then it's fine. The engine runs smooth before and after. Initially I thought it might be the transmission and they did do a firmware update but that didn't help and as time went on I'm pretty sure it's engine related now. Every time the dealer has it, they seem to update firmware. Anyone else have this happen?
 

·
Registered
Joined
·
27 Posts
Does oil pressure drive the fuel injectors in the GC like it does in Ford powerstrokes? I'm guessing it does, so the next question is if there's an oiling issue...I've got 420,000+ miles on my PSD and everynow and again at first start up it'll sort of 'hiccup' too (great term!)....that's when I find the oil level is a tad low..not a terminal condition, but just top it off and good to go....just a thought.

RS
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thats a very interesting thought...I will keep an eye on that. Thanks!!!
 
1 - 3 of 3 Posts
Top