Diesel Jeep Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
218 Posts
My guess would be that the line leak at the radiator was transmission fluid. It's just too coincidental that your trans would be 2.5 qts low at the same time this leak occurred.

I'd suggest that you take it back to the dealer you purchased it from (or a dealer with a competent service dept) and have them check everything out. The dealer is responsible for the pre-delivery vehicle inspection, which includes checking all fluid levels before delivery to the customer.

I'm going to say that your trans is probably still okay as limp mode is designed to minimize or prevent damage to the engine/trans when a problem is detected. However, I would make damn sure to voice my displeasure with the dealer who failed to do proper vehicle prep and I'd also make damn sure that all of this is properly noted in your service file so that it's on record in case there is a problem down the road.


Note: I deleted this same post in another thread as well as a second identical thread to this.
 

· Registered
Joined
·
218 Posts
On my V6 gas, the lines coming in to the top passenger side of the radiator appear to be coming from the transmission as they're coming out from underneath that side of the engine and do not appear connected in any way to the power steering system. Power steering lines go to the drivers side from what I can see.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top