Diesel Jeep Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
165 Posts
Discussion Starter #1
Took delivery mid May of a 'Bright White' one. Current miles @ ~1500. Very well thought out vehicle- and although expensive I think you get every pennies worth for your $.

For everyone's reference I only had one 'fluke' occur- I got a 'Service DEF system alert' and 'check engine light' came on one day. I was parked at very end of parking spaces and I turned wheel over right to do a U turn out of space. Did turn fairly quick (still getting use to that 'torque') - and that's when warning came up. I drove home no problems and thought to check the DEF level- It was at around 45%; which I guess is par for dealership failing to top it off. Next day check engine light was still on- but there were no messages in the message center. I went to NAPA and got Valvoline DEF and topped off to around 90%. Before I contacted service (mainly because I had nothing showing in the 'message center') - I saw on forums if the problem does not repeat after so many cycles the check engine light will reset itself. Sure enough that was the case. So just guessing - when I made that 'hard right' it must have sloshed the DEF and maybe gave a false 'DEF issue' flag.

As to MPG I drive 'country/mixed roads' on my commute and showing 27-28 consistent :). On next fill-up I'm going to add 'Opti-lube' conditioner- and I'll report back on any changes.
 

·
Registered
Joined
·
165 Posts
Discussion Starter #3
Any mileage increase with opti-lube?
Can't say I have (for sure). I've been getting around 27 mpg on 'mixed driving'. My best tank was a trip on I-80 where I averaged 29.3 - which I was really pleased! I just ordered some of their winter formula- which will treat fuel down to -50 F (vs the -20 F on the regular stuff). Seems to be a quality product- even if you use it once and awhile should keep things clean and flowing smoothly.
 
1 - 3 of 3 Posts
Top