Diesel Jeep Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
My dealer tells me they have finally received the revised AEM flash from FCA. I'm debating on taking it back in but my thinking is that there is no way it can be any worse than the original...but perhaps I'm being naïve. Has anyone had this done yet and is there any improvement over the original POS AEM install that we were all duped with last year?

My MIL has been on for about 3 months now and i just received another "Service DEF system" message the other day. It's only a matter of time before I'm forced to take if in. I asked the service manager if it's an actual improvement and he said was other customers are telling him its better. Such great detail....
 

·
Registered
Joined
·
76 Posts
I have both the Ram & JGC EcoD. The flash is VA7 on the Ram. I just ran my VIN for the JGC & it doesn't show up as completed or outstanding. Let us know if you take yours in to have it flashed. I've heard the flash is a good update on the Rams.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #3
Soooo...had the update installed this morning and just like everything else involved in this fiasco involving the emissions (SCR) lawsuit it's a good news/bad news situation. Good news first...the Jeep appears to be back to normal from an operational standpoint. Hesitation is gone, acceleration is back, obviously cannot speak about the lost MPG's quite yet but i will continue to monitor and report back. The bad news is my MIL light came back on when i went out for lunch. Lasted a whole 2 hours and ~10 miles with no light. It was a glorious 10 miles though!! Maybe this is just a way of life moving forward with this vehicle. Probably heading back in soon to see what the code is this time.

Some History about this update....I, like many of you, received a letter from FCA several months ago regarding an update to the AEM that was installed last year. It was vague and FCA passed it off like this was a rare issue only affecting a small number of customers, but we all know this is nonsense. In speaking with my dealer this morn they only received this "update" last week. I am the third customer to have it installed in my area so the verdict is definitely still out. I'll need more time behind the wheel to recommend everyone contact their dealer to get the update. For now it's better, but we'll see what the new code says.
 

·
Registered
Joined
·
76 Posts
I like your "good" news. Sorry to hear your MIL came back on.

Do you have a code reader? I would recommend the MX OBD coupled with AlfaOBD. Works great provided you have an android device (or laptop).
 

·
Registered
Joined
·
54 Posts
Discussion Starter #5
I like your "good" news. Sorry to hear your MIL came back on.

Do you have a code reader? I would recommend the MX OBD coupled with AlfaOBD. Works great provided you have an android device (or laptop).
I do not but it may be time to invest in one. It is the VA7 Recall. I wonder if FCA released it for the Ram first since there is quite a bit more of them than the Jeeps.
 

·
Registered
Joined
·
76 Posts
What year is your JGC?

IIRC, the MX ~$40 & Alfa App ~$50. Pretty cheap reader plus you can do a million other things to the ECM. I used it to swap a GDE ECM in Ram & eliminate CEL for my LED fogs. I'll be using it to reprogram TPMS on new wheels for JGC in the next couple of weeks.

From what I'm reading the VA7 has only been uploaded in the last month on the Rams. I really like my JGC, but the hesitation & now low MPGs is making me want to get rid of it. If the VA7 solves this, the wife will be happy... happy wife, happy life!!
 

·
Registered
Joined
·
54 Posts
Discussion Starter #7
Back at the Dealer. This has nothing to do with the Header and the VA7 update but wanted to provide more frustrating (humorous) details in my life with the Jeep and the latest MIL. I was told a sensor broke off and lodged into my DPF thus causing a new MIL. New sensor and DPF being installed now. Funny how this happened less than 10 miles after the last VA7 update. I'm certain the two have absolutely nothing to do with each other...wink wink. FCA would have been better off taking $10-$15K off a new vehicle for me with all the time and parts they've given me the last 12 months.
My dealer service dept continues to laugh with me and cover everything...except the 6 hours of my life lost waiting the past week. To be continued....
 

·
Registered
Joined
·
76 Posts
Just checked Mopar site & says VA7 was completed... Well, don't tell my wife that. Still runs like crap. Has anyone tried to get dealer to re-load a "campaign"?
 

·
Registered
Joined
·
12 Posts
Just got mine completed today. On my way home, with a detour to pick up some dinner, the check engine light came on. I called the dealer and was told to bring it by first thing in the morning. Now when i remote start the vehicle it cuts off about 30 seconds after. Ran my OBDII reader and the code pulled is P245B, EGR Cooler Bypass.
WTF, i've never had these issues, nor have i ever had the check engine light come on
 

·
Registered
Joined
·
76 Posts
Just got mine completed today. On my way home, with a detour to pick up some dinner, the check engine light came on. I called the dealer and was told to bring it by first thing in the morning. Now when i remote start the vehicle it cuts off about 30 seconds after. Ran my OBDII reader and the code pulled is P245B, EGR Cooler Bypass.
WTF, i've never had these issues, nor have i ever had the check engine light come on
A CEL will do exactly what you described for the remote start.
 

·
Registered
Joined
·
12 Posts
yea i just got back from the dealer and thats what they said, i wasnt aware of that. The CEL is being caused by a closed EGR Valve. The valve is special order and on back order. According to them its a newly redesigned EGR.
 

·
Registered
Joined
·
6 Posts
I had my flash installed 2 weeks ago. No problems except that Fiat Chrysler won't acknowledge and confirm that my vehicle has the Approved Emissions Modification installed. What the hell takes so long??? It's all digital and done by a certified dealer. Y'all experiencing the same?
 

·
Registered
Joined
·
76 Posts
I had my flash installed 2 weeks ago. No problems except that Fiat Chrysler won't acknowledge and confirm that my vehicle has the Approved Emissions Modification installed. What the hell takes so long??? It's all digital and done by a certified dealer. Y'all experiencing the same?
I had to call dealer to get their warranty folks to submit paperwork.
 

·
Registered
Joined
·
6 Posts
Me too...I'm told it stuck in purgatory called "RA status." Basically means the FCA boneheads are picking their noses instead of doing their work. Any secrets on how to get RA status expedited? Thanks for your note.
 

·
Registered
Joined
·
6 Posts
I've spoken with my dealer several times. They perform all the warranty work and wait for blessings on high to move these along and to get paid. 16 days after installation, the Fiat Chrysler gods finally checked the right box and my claim was approved. Some people talk about running government like a business - FCA runs their company like it's government. Beats all I've ever seen.
 

·
Registered
Joined
·
10 Posts
Ran my OBDII reader and the code pulled is P245B, EGR Cooler Bypass.
WTF, i've never had these issues, nor have i ever had the check engine light come on
[/QUOTE]
I had the update done last August....all fine for about 2,000 miles, then "Exhaust gas regeneration in progress". This occurred 2 or 3 times then "Exhaust filter almost full", then "Exhaust filter full". Went to the dealer was told "regen" should have taken care of this but we'll clean it out. $140 later (not covered)
About a month later "check engine" light on..."EGR valve slow to react" Went to dealer, "checks OK" and reset. Drove 12 miles...same light. Went to dealer, ordered an new EGR valve....it's been 5 WEEKS, no valve. Blamed on COVID delays....:rolleyes:
 

·
Registered
Joined
·
12 Posts
my egr took about 10 days to get to the dealership and half a day to install. Now with that taken care of i havent come across any other issues(knock on wood) I have noticed an increase on AVG MPG on the computer, ive seen upwards of 23+ mpg where ass before it would stay around 20-21. On my last fill-up my maintenance app showed i averaged exactly 23 MPG since the last fill up, which is when i got the update and the new EGR. Still too early to tell my so far this new update seems promising in regards to MPG
 

·
Registered
Joined
·
18 Posts
Soooo...had the update installed this morning and just like everything else involved in this fiasco involving the emissions (SCR) lawsuit it's a good news/bad news situation. Good news first...the Jeep appears to be back to normal from an operational standpoint. Hesitation is gone, acceleration is back, obviously cannot speak about the lost MPG's quite yet but i will continue to monitor and report back. The bad news is my MIL light came back on when i went out for lunch. Lasted a whole 2 hours and ~10 miles with no light. It was a glorious 10 miles though!! Maybe this is just a way of life moving forward with this vehicle. Probably heading back in soon to see what the code is this time.

Some History about this update....I, like many of you, received a letter from FCA several months ago regarding an update to the AEM that was installed last year. It was vague and FCA passed it off like this was a rare issue only affecting a small number of customers, but we all know this is nonsense. In speaking with my dealer this morn they only received this "update" last week. I am the third customer to have it installed in my area so the verdict is definitely still out. I'll need more time behind the wheel to recommend everyone contact their dealer to get the update. For now it's better, but we'll see what the new code says.
I had VA7 installed on July 29 at 64,600 miles on my 2016 Overland. (They also show a W41 recall update on the invoice. Same thing or something else new?) I'm now at 66,000 miles and will be calling the dealership tomorrow to schedule an appointment to see what they did to almost totally destroy my Jeep - under certain circumstances the thing shudders and shakes like the engine/transmission is going to fall out! It seems to happen mostly within the first 10-15 miles of driving and at shift points - feels kind of like the tranny is hunting between two gears and can't decide which to use. However, using the paddles to manually select a gear doesn't stop the "shakes" from continuing. Wish I'd never had AEM or VA7 done. I'm thinking about getting the GDE hot tune and be done with FCA's garbage software.
 
1 - 20 of 22 Posts
Top