Diesel Jeep Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
I'm having a weird issue with my 2008 grand cherokee with the 3.0l diesel in it. When I first start it and until the temp gauge is almost to the middle I have tons of air flow through my vents but once it is warmed up its less than a fart blowing through. I checked those flapper doors under the glove box and the one for the recirculation and those all seem to be working properly. Is this a thermostat problem? Coolant is full but looks a little dirty could that be it? Any help would be appreciated thanks
 

·
Administrator
Joined
·
21 Posts
I'm having a weird issue with my 2008 grand cherokee with the 3.0l diesel in it. When I first start it and until the temp gauge is almost to the middle I have tons of air flow through my vents but once it is warmed up its less than a fact blowing through. I checked those flapper doors under the glove box and the one for the recirculation and those all seem to be working properly. Is this a thermostat problem? Coolant is full but looks a little dirty could that be it? Any help would be appreciated thanks
Welcome to the forum.

This should not be related to the engine thermostat or the coolant. Those would affect the air temperature, but not the volume. Is this a new problem?

What HVAC controls do you have? If your control has a temperature temperature setting there may be a reduction in air when the setpoint is reached.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Thank you! I noticed it last year but it seemed to do it randomly. This winter I noticed it seemed to correlate with the engine temperature. I've only had the jeep for 2 years as I bought it used.
The controls do have temperature setting ( it's dual climate control if that matters) they go from 18-26 and then the final setting is "hi" which I have it set for and I also made sure it wasn't in the auto setting. I wonder if when I set it to hi it's not actually going to that setting and getting stuck on 26 or one of the lower settings and cutting out like you said. Any idea on how one would check that?
 

·
Administrator
Joined
·
21 Posts
If it was random it seems less likely to be intentional, especially the way you have the controls set.

Unfortunately I don't know enough (anything really) about that model to give you any intelligent suggestions.

Can you tell if the fan slows down? It could be that a diverter is closing when it shouldn't.
 
1 - 7 of 7 Posts
Top