Diesel Jeep Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello,

I’ve been having endless issues with the P203C code on my 2015 Diesel Grand Cherokee. The vehicle has has the following completed by the dealer:

  • Several replacements of the DEF tank (5)
  • Replacement of the Wiring harness to the DEF tank
  • Replacement of the PCM
This jeep only has 30K miles on it. Has anyone had similar problems and what was the solution? This is getting very frustrating. What else could be throwing this code?

Any help would be appreciated.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Update on the issue...

After the Jeep being in the shop for over 3-weeks, the root cause ended up being a wire that was abraided through in the main wiring harness above the fuel tank.

Seems to be running great now... Just need to get some miles behind me to help assure that this was the true root case.
 

·
Registered
Joined
·
4 Posts
Update on the issue...

After the Jeep being in the shop for over 3-weeks, the root cause ended up being a wire that was abraided through in the main wiring harness above the fuel tank.

Seems to be running great now... Just need to get some miles behind me to help assure that this was the true root case.
So was that the issue? Also, does your name indicate Ohio State? If so, are you near Columbus?
 

·
Registered
Joined
·
4 Posts
I'm in Hilliard area...I've seen one other EcoDiesel Jeep here...also black like mine. Its the only one I've ever seen in Columbus area.
 

·
Registered
Joined
·
54 Posts
I'm in Hilliard area...I've seen one other EcoDiesel Jeep here...also black like mine. Its the only one I've ever seen in Columbus area.
Clintonville here. My neighbor has one so I see another one all the time. :D

I see others from time to time but certainly not nearly the frequency of the gas version.
 
1 - 6 of 6 Posts
Top